Append API version to version number

Description

Follow semantic versioning, but append "-{API-VERSION}" to version number. I.e. 4.2 becomes 4.2-5. This way e.g. EntryStore.js and EntryStore do not have to have the same version number but it is clear anyways that e.g. ES.js 2.0-5 and ES 4.2-5 are compatible.

Environment

None

Activity

Show:
Hannes Ebner
April 23, 2015, 12:11 PM

Probably unnecessary if ES.js is the only client we maintain. We can keep ES.js at the same version number (major.minor) to ensure API-compatibility.

Won't Fix

Assignee

Hannes Ebner

Reporter

Hannes Ebner

Labels

None

Fix versions

Priority

Normal